This is a public Forum  publicRSS

Topic

    Muthulakshmi Muthaiah
    Sales accelerator Error when Configuring
    Topic posted January 5, 2017 by Muthulakshmi MuthaiahExpert, last edited January 10, 2017 by Danette BealElite 
    136 Views, 11 Comments
    Title:
    Sales accelerator Error when Configuring
    Content:

    Hi All,

    Based on the answer-https://cx.rightnow.com/app/answers/detail/a_id/4755,we have configured the sales accelerator in OSvC. But we are facing issue while creating the Lead in OSvC. We are getting the following error even though we have configured all the setups based on the document."Please contact your support,the integration with Oracle Sales is not setup correctly for this Service site".

    Kindly give me some idea to overcome this issue.

    NOte :Git hub-https://github.com/oracle/accelerators/tree/master/salescloud.

    Thanks,

    Muthu

    Edited by Danette to clarify subject

    Answer

     

    • Barrilito

      Hi Muthulakshmi Muthaiah,

      I am not known with this accelerator, but the error is clear that the setup is not correct. I would say, raise a service request at Oracle to let them look at your settings.

      Regards

    • Muthulakshmi Muthaiah

      Hi Barrilito,

      Thanks for the reply.We have already raised this issue at Oracle side,but we didn't get a proper response from them.So only we have posted in the community forum.

      They have said that its part of Oracle Consulting Team.

       

      Thanks,

      M.Muthulakshmi

    • Barrilito

      Hi,

      I understand. Sorry to hear. Yes, many things will be redirected to payed consulting services I guess.

      Well, as I said, this is not my expertise. Perhaps someone else can help out. It may help if you perhaps tell a little more about your setup and at what moment you get this error. Good luck anyway.

      Regards

    • Scott Harwell

      Hi Muthu,

      The accelerators are example code, not a productized component of Service Cloud, so Customer Care can't help with issues with the accelerator.

      Can you provide a little more information about your setup and issue?  Was your organization the group that compiled this version of the add-ins, or did you receive the DLL from another party?  Did you make any changes to the add-in(s)?  Have you configured them for leads, not opportunities?  Does the error only occur on create, or on workspace load too, meaning, do you get results in the report add-in (reading data from Sales Cloud).  Are you able to capture the communication requests between OSvC and OSC to see whether the SOAP requests contain any useful information about what Sales Cloud is expecting but not getting?

    • Muthulakshmi Muthaiah

      Hi Scott Harwell,

      Based on the answer/document(http://www.oracle.com/technetwork/indexes/samplecode/accelerator-osvc-2525361.html),we have configured the sales accelerator.while saving the lead,we are getting the attached error like "Please contact your support,the integration with Oracle Sales is not setup correctly for this Service site".

      We don't know what we have missed in the configuration.If the setup is missing, we couldn't see the opportunities in the service cloud.But we can see all the opportunities are created in sales cloud,is visible in the service cloud.

      Kindly give me some idea to overcome this issue.

      Thanks,

      Muthu

    • Scott Harwell

      Muthu, it would help if you answered the rest of the questions from earlier so that we have the context of how you configured the accelerator.  For now, we'll assume that you're compiling the add-ins on your end.

      Did you implement separate reports, one for leads and one for add-ins?  The report add-ins included in the accelerator do require two separate reports.  Also, depending on your configuration, you're likely pulling back opportunities or leads, but not both.

      {
        "rnt_host": "osc-
        svc - integration.example.com ", 
        "integration": {
            "server_type": "Sales",
            "sales_base_url": "https://salescloud.example.com:10616",
            "username": "mhoope",
            "password": "Welcome1",
            "sales_timeout": 30000,
            "sales_max_rcvd_msg_size": 0,
            "oppty_lead_type": "opportunity",
            "oppty_service_url": "https://salescloud.example.com:10616/ 
            opptyMgmtOpportunities / OpportunityService ", 
            "acct_service_url": "https://salescloud.example.com:10616/ 
            crmCommonSalesParties / AccountService ", 
            "lead_service_url": "https://salescloud.example.com:10616/ 
            mklLeads / LeadPublicService ", 
            "ctc_service_url": "https://salescloud.example.com:10616/ 
            crmCommonSalesParties / ContactService " 
        }
      }
      
      

      I would suggest that you use Visual Studio to attach a debug process to the agent console, then set some breakpoints around the method(s) that are making calls to Sales Cloud.  Once the add-in is loaded and run in your workspace, then Visual Studio will stop at the break point and you can see what data is being returned from Sales Cloud in the debugger.  Likely, Sales Cloud isn't returning something that is expected by the add-in, in which that generic popup message occurs (which you would probably want to change to be more specific to your employer/consulting agency since your group is implementing the accelerator).

    • Muthulakshmi Muthaiah

      Hi Scott,

      We have uploaded the add-ins which we got from the sales accelerator git hub.But we couldn't downloaded the source code from the Git hub.

      I have attached the addin files.Could you help me how to get the source code from these files.

      Thanks,

      Muthu

    • Scott Harwell

      There are no compiled versions of the Sales Cloud add-ins on GitHub; you probably got the compiled versions from TechNet.  The solution for the add-ins is available here, which contains all of the source that you need to compile to build the add-ins.  I'd suggest building the add-ins yourself so that you can leverage the Visual Studio debug tools, and change the accelerator to meet your needs.

      Did you review the highlighted config area in the above comment?  Is oppty_lead_type set to opportunity, and not lead, in your setup?

    • Muthulakshmi Muthaiah

      Hi Scott Harwell,

      Thank you so much for the response.We could n't download the source code from the link "https://github.com/oracle/accelerators/tree/master/salescloud/cx/projects" which you mentioned in the previous comment.Is there any way to download the source code,let me know.

      And also I changed the config area, but it didn't work.Kindly help me to solve this issue.

       

      Thanks,

      Muthu

    • Muthulakshmi Muthaiah

      Hi Scott,

      Please find the answer for your previous question.Apologize for the late reply.

      1.Can you provide a little more information about your setup and issue? 

      Answer :

      We have configured based on the git hub,Kindly find the configuration settings we have used below.


      {

      "rnt_host": "https://******",

      "integration":

      {"server_type":"Sales",
      "sales_base_url":"https://sitename.oraclecloud.com",

      "username":"EXAMPLE",
      "password":"******",

      "sales_timeout":30000,

      "sales_max_rcvd_msg_size":0,

      "oppty_lead_type":"saleslead",

      "oppty_service_url":"https://******/opptyMgmtOpportunities/OpportunityService",

      "acct_service_url":"https://******/crmCommonSalesParties/AccountService",

      "lead_service_url":"https://******/mklLeads/LeadPublicService",

      "ctc_service_url":"https://******/crmCommonSalesParties/ContactService"

      }

      }


      And we are getting the error while creating the lead record in the workspace level of OSvC "Please contact your support,the integration with Oracle Sales is not setup correctly for this Service site".The error is different from the error which is mentioned in the document in the git hub.So we couldn't proceed further.

       

      2.Was your organization the group that compiled this version of the add-ins, or did you receive the DLL from another party? 


      Answer :

      We have used the add-in as provided by the GitHub and configured in RightNow and we dont use any third party dll.


      3.Did you make any changes to the add-in(s)? 


      Answer :

      No we didnot make any changes in code level.

      4.Have you configured them for leads, not opportunities? 

      Answer :

      we have configured them for both lead and opportunities as mentioned in the git hub document.

      5.Does the error only occur on create, or on workspace load too, meaning, do you get results in the report add-in (reading data from Sales Cloud).  

      Answer :

      Error occured at the time of lead record creation(error is already mentioned in the question 1) and we get results from sales cloud in the report for opportunities.

      6.Are you able to capture the communication requests between OSvC and OSC to see whether the SOAP requests contain any useful information about what Sales Cloud is expecting but not getting? 

      Answer :

      Getting the communication request result between OSvC and OSC for opportunities, not for lead.

       

      Thanks,

      Muthu

    • Scott Harwell

      Muthu,

      It might help to explain the context of the errors in the accelerators.  As mentioned previously, these are example sets of code for various integrations.  Each one contains its own set of error messages that are included in the code, but they are up to the implementing SI or customer to change or make relevant.  In the case of "support" messages, those are default messages for an end user of the accelerator to contact their support organization, which is the implementing SI for most customizations.  The error is defined on line 81 of this file in the repo: /salescloud/cx/projects/Accelerator.SalesCloud.Client/Common/OSCStringConstants.cs

      public static readonly string OracleSalesIntegrationSiteWarningMessage = "Please contact your support, the integration with Oracle Sales is not setup correctly for this Service site."
      

      That file should help you track down the variable used to throw the message.

      With that variable, you can traverse back to the usages.  OracleSalesIntegrationSiteWarningMessage is used in only 1 file and in 1 method, line 41 of /salescloud/cx/projects/Accelerator.SalesCloud.Client/Common/OSCCommonUtil.cs

      In looking at that method, it appears to be name of the RightNow host to the host of the current client (which means the error is misleading since the error points to sales cloud).  That pointed me to your listing in the config above for rnt_host.  You have the protocol defined in the config; https://my-host.custhelp.com.  Remove "https://" and see if that helps your issue.