This is a public Forum  publicRSS

Topic

    Mike Waldron
    BUI Extension Intermittently Refuses to LoadAnswered
    Topic posted September 13, 2018 by Mike WaldronSpecialist 
    38 Views, 4 Comments
    Title:
    BUI Extension Intermittently Refuses to Load
    Content:

    I have a real-world, multi-file BUI workspace extension that's not loading for me. In Chrome's developer tools, under the Application tab → Cache Storage → OSVC-Extension-Cache, all I see is my index.html file loading, and nothing else. If I click on the index.html file, all I see in the preview window is:

    <script src="https://xyz.custhelp.com/AgentWeb/api/agentbrowserui/v.31809060018/module/extensibility/js/client/core/extension_loader.js?v=31809060018"></script>
    

    Which is an automatically-injected line. I see zero lines of index.html. There are no errors showing in the dev tools console, and nothing looks particularly useful in the verbose section either. I've seen this a few different times, but I have no idea what causes it and it brings work to a screeching halt. The permissions all check out, the workspace is properly configured, I've done all the troubleshooting I can think of. What's more, it was working fine a few hours ago.

    Has anybody seen this? Does anyone have any insight to offer here?

     

    Best Answer

    Colin McWilliams

    At risk of stepping on Mike's toes here, just wanted to say that the issue has been resolved.  It was tied back to an early release defect in the test environment, and was addressed quickly after it was reported. 

    Oracle's Dev team rules!  Thanks for the fast assist, guys!

    Answer

     

    • Colin McWilliams

      At risk of stepping on Mike's toes here, just wanted to say that the issue has been resolved.  It was tied back to an early release defect in the test environment, and was addressed quickly after it was reported. 

      Oracle's Dev team rules!  Thanks for the fast assist, guys!

    • Suhail Tahir

      As we have getting the same problem, how will you fix the push. Do we need to update our ServiceCloud solution. 

      We are trying to built and BUI extension.

    • Mike Waldron

      There isn't a great answer here, but Colin's comment is about as close as we're gonna get.

    • Colin McWilliams

      Hi Suhail -- it was apparently an issue with a new BUI build released to the test environment.  They rolled back the edit and the issue went away.  I believe they are advising that you report the issue in a SR to Oracle Customer Care if you run into it, and they can help revert the site.  Good luck!