This is a public Forum  publicRSS

Topic

    vivted
    Issues with installations after TLS1.1 changesAnswered
    Topic posted February 8, 2017 by vivtedExpert 
    621 Views, 8 Comments
    Title:
    Issues with installations after TLS1.1 changes
    Content:

    Has anyone else had issues with installations of the Service Cloud tool since the TLS 1.1 changes?  We have two call centers who are having issues.  One is trying to roll out a bunch of new computers but no matter what they do, they cannot seem to install Oracle Service Cloud.  They had no issues on Tuesday but started having issues on Wednesday of last week. They have updated their group policy (as was described in one FAQ) and in one case also written a rule in a firewall to allow the download which worked for a few users but not all.  But for some computers they are still getting errors like "cannot start application."  Any suggestions that might have worked for you would be helpful.

    Version:
    May 16

    Best Answer

    Corbin Midgley

    You need .NET Framework 4.6.2. Oracle is not proactively telling customers this, but it is a known issue that we were told about through a service request.

     

    Answer

     

    • Dietrik

      Why would this be a tls issue ?  The support will end march 31, not last week.

       

    • Andrew M

      It ends March 31st for non PCI sites but January 31st for PCI sites.

    • Ryan

      @Vivted -

      Specific error messages and steps taken to encounter them would be useful here.  There's a bug in 16.11 that causes issues w/downloading the manifest, but nothing I'm acutely aware of in 16.5.

      R

    • vivted

      The full error is

      Application download did not succeed.  Check your network connection or contact your system administrator or network service provider.

      and the details are

      PLATFORM VERSION INFO
          Windows             : 6.1.7601.65536 (Win32NT)
          Common Language Runtime     : 4.0.30319.42000
          System.Deployment.dll         : 4.6.1055.0 built by: NETFXREL2
          clr.dll             : 4.6.1055.0 built by: NETFXREL2
          dfdll.dll             : 4.6.1055.0 built by: NETFXREL2
          dfshim.dll             : 4.0.41209.0 (Main.041209-0000)

      SOURCES
          Deployment url            : https://installer-cendant-cta.custhelp.com/RightNow.Installer.application?launch=https://yahootravel.custhelp.com/cgi-bin/yahootravel.cfg&dbname=cendant_cta&trace=true&lang=en_US

      ERROR SUMMARY
          Below is a summary of the errors, details of these errors are listed later in the log.
          * Activation of https://installer-cendant-cta.custhelp.com/RightNow.Installer.application?launch=https://yahootravel.custhelp.com/cgi-bin/yahootravel.cfg&dbname=cendant_cta&trace=true&lang=en_US resulted in exception. Following failure messages were detected:
              + Downloading https://installer-cendant-cta.custhelp.com/RightNow.Installer.application?launch=https://yahootravel.custhelp.com/cgi-bin/yahootravel.cfg&dbname=cendant_cta&trace=true&lang=en_US did not succeed.
              + The request was aborted: Could not create SSL/TLS secure channel.

      COMPONENT STORE TRANSACTION FAILURE SUMMARY
          No transaction error was detected.

      WARNINGS
          There were no warnings during this operation.

      OPERATION PROGRESS STATUS
          * [2/2/2017 11:21:36 PM] : Activation of https://installer-cendant-cta.custhelp.com/RightNow.Installer.application?launch=https://yahootravel.custhelp.com/cgi-bin/yahootravel.cfg&dbname=cendant_cta&trace=true&lang=en_US has started.

      ERROR DETAILS
          Following errors were detected during this operation.
          * [2/2/2017 11:21:37 PM] System.Deployment.Application.DeploymentDownloadException (Unknown subtype)
              - Downloading https://installer-cendant-cta.custhelp.com/RightNow.Installer.application?launch=https://yahootravel.custhelp.com/cgi-bin/yahootravel.cfg&dbname=cendant_cta&trace=true&lang=en_US did not succeed.
              - Source: System.Deployment
              - Stack trace:
                  at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
                  at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
                  at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState)
                  at System.Deployment.Application.DownloadManager.DownloadManifestAsRawFile(Uri& sourceUri, String targetPath, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
                  at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirectBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
                  at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options)
                  at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
                  at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
              --- Inner Exception ---
              System.Net.WebException
              - The request was aborted: Could not create SSL/TLS secure channel.
              - Source: System
              - Stack trace:
                  at System.Net.HttpWebRequest.GetResponse()
                  at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)

      COMPONENT STORE TRANSACTION DETAILS
          No transaction information is available.


      They have downloaded the certificate locally but that is not helping as well as changing group pollicy.

    • Scott Harwell

      Looks like you're using Win7.  Are you using a version of IE lower than 11?  If using IE 8 - 10, you probably need to have your users manually enable TLS1.1/1.2 in IE's settings.  My guess is that your users who have not had an issue already have these versions of TLS enabled in IE, while those that are experiencing the issue do not have the newer versions of TLS enabled.  You can check browser support for SSL/TLS versions in this article.

    • vivted

      They have advised that they have all updated the TLS1.1 and 1.2 settings on their browsers as well as the .Net versions, but I will double check with them. 

    • Corbin Midgley

      You need .NET Framework 4.6.2. Oracle is not proactively telling customers this, but it is a known issue that we were told about through a service request.

       

    • vivted

      Corbin - thank you so much for that tidbit - that worked!  I think Oracle should definitely have an FAQ or something about requiring .Net 4.6.2 for installs after these changes. The user was on IE 11 so that was fine. 

      I found even before the changes that on Windows 10 I could not even get the admin tool to stay open for longer than an hour or so without memory errors until I updated to .Net 4.6.2.  I still get memory errors but only 4-5 times a day instead of 15-20 times a day.