This is a public Forum  publicRSS

Topic

    Anthony Smith
    Upgrade site clone availability on EOL versionsAnswered
    Topic posted October 11, 2017 by Anthony SmithWhiz 
    45 Views, 8 Comments
    Title:
    Upgrade site clone availability on EOL versions
    Content:

    Hi there

    Just wondering whether anyone has come across an issue of not being able to clone their site for upgrade because it was EOL? E.g. let's say site X is currently on version August '14, would anything stop me from logging into https://hms.custhelp.com/cgi-bin/ssm-login.py and requesting an upgrade?

    One detail is that it is possible that there was an upgrade clone site created over a year ago. So that old clone site would need to be overwritten, it is not feasible to upgrade the outdated clone site and then try and apply all the config, dev, content and other changes accumulated over this time.

    Has anyone experienced any issues re-creating an upgrade clone site in an EOL environment before?

    Best Answer

    Nate Hossner

    Hi Anthony,

    It is possible to clone any instance of Service Cloud, regardless of version. However, the portal at https://hms.custhelp.com is for requesting upgrades, rather than requesting clones. If you were unable to request an upgrade through that portal it is possible that there's already an upgrade in flight for that site. Another restriction occurs if the site is already on the latest release, but that isn't the case here.

    If you're looking to destroy an existing upgrade clone and create a new upgrade clone, that option is only available to Oracle technical staff; it is not available through any customer-facing portals.

    You can report this to Technical Support for investigation. If you provide me the details, I can assist.

    Answer

     

    • Tommy Widner

      Which site are you referencing?  I can look deeper into the actual circumstances surrounding this site.

      In general, because there was already an Upgrade site built in the past, the site is "locked-in" to the original, targeted upgrade release.  There is no way to change that target.  The site must complete the upgrade to 'THAT' release prior to re-targeting another version.

      Reference Answer ID 9596 - Changing a target version after upgrade site creation

      As for the situation you have, it sounds like you just need to "refresh" the current Upgrade site.  If the original was destroyed at some point, it will be re-created.  This will rebuild it from a fresh clone from the current Production environment and then upgrade that clone, to the targeted release version.  This is the typical step we take in a case as you describe it.

    • Nate Hossner

      Hi Anthony,

      It is possible to clone any instance of Service Cloud, regardless of version. However, the portal at https://hms.custhelp.com is for requesting upgrades, rather than requesting clones. If you were unable to request an upgrade through that portal it is possible that there's already an upgrade in flight for that site. Another restriction occurs if the site is already on the latest release, but that isn't the case here.

      If you're looking to destroy an existing upgrade clone and create a new upgrade clone, that option is only available to Oracle technical staff; it is not available through any customer-facing portals.

      You can report this to Technical Support for investigation. If you provide me the details, I can assist.

    • Carl Elliott

      I have seen the need for two upgrades to be required,  the site couldn't jump from their current release to the latest, it had to be upgraded to a site in-between first.  

      And a previous upgrade site would need to be deleted if it was never installed. 

    • Anthony Smith

      Awesome thanks very much Nate. I'm trying to assist one of my customers with an upgrade from an EOL version and seems the current understanding of their support staff is that you cannot destroy and recreate an old upgrade clone, which didnt make sense to me since that would make it difficult for customers to upgrade.

      Thanks again for such quick reply, I'll let them know that you can request an upgrade clone to be recreated by submitting a support ticket

    • Anthony Smith

      Thanks Carl

      Yup my understanding is that the upgrade is currently aimed at upgrading to an older (but still supported) version, perhaps for those exact reasons.

    • Anthony Smith

      Hey thanks for your reply Tommy. At this point I'll let customer's IT staff to have a go at it, contact Oracle, etc, just trying to give them as much information as possible as it seemed there was some concern that the outdated upgrade clone is all we have to work with, which would've caused some series issues.

    • Nina Notomi

      > I'm trying to assist one of my customers with an upgrade from an EOL version and seems the current understanding of their support staff is that you cannot destroy and recreate an old upgrade clone, which didnt make sense to me since that would make it difficult for customers to upgrade.

      This depends on a number of things. Upgrade site refresh (= destroy & re-create) can be done fairly easily for Auto Upgrade Program sites, provided there is no PHP remediation involved. Upgrade site refresh cannot be done for legacy upgrade sites. Please submit a service request, and we can determine whether it is possible to refresh or not. 

    • Anthony Smith

      Thanks Nina, yup that's what we've advised them to do, hopefully they'll have it resolved soon.