This is a public Forum  publicRSS

Topic

    Mirela Iepure
    Custom message sent to customer vs agent when a business...
    Topic posted February 17, 2017 by Mirela IepureWhiz 
    48 Views, 9 Comments
    Title:
    Custom message sent to customer vs agent when a business Rule is active
    Content:

    Hello,

    I have a question regarding the notification email that the Agent is getting when an Incident notification is sent via email.

    I mean, I want the agent to get an email notification about the Incident's Status without the Auto-response from the Administrator. Please see the attached image for Agent and customer.

    I created different email notification Rules for Agent and customer but they seem to get the same structure of email notification with the auto-response from Administrator.

    As suggested by some of the community members I should customize the Rule Email I send to the customer but I have different messages I need to send depending on the time passed since the Incident was created. I used instead the standard text messages included in the email notification to be easier for customer to access the incidents details on the website.

    Can you have a solution to my issue to remove the auto-response from the Agent notification?

    Thank you,
    M.

    Version:
    Service Cloud November 2016 version
    Image:

    Answer

     

    • Sebastiaan

      Hi there

      Sending different messages should not be a problem. You could specify to send a message in your escalation rule if that is what you mean with "I need to send depending on the time passed since the Incident was created". In your THEN actions you choose Email > Send escalation message and check the To assigned box.

      To disable the Administrator messages you need to open your Message templates for Administrator and disable the one for Updated

    • Mirela Iepure

      Hi Sebastiaan,

      I am not sure if there is a message template issue. The message that I am sending to the customer is by using:

      Then > Append Response Template to Response Field 
      Email > Send Email Response to Sender

      In the response field I have a created a Standard text which the following: 

       

      Hello,
      Your incident $incidents.ref_no has been updated. 
      $response_link

      The Administrator puts this also as an automated response to the Incident, basically everything is doubled. This part shouldn't appear in the Agent's email notification and it shouldn't be doubled also in the Customer's email notification. The important part is that the response link to make easier access the website for customer and see the Incident's details.
      Thank you,
      M.

    • Sebastiaan

      Hi Mirela.

      My apologize. I might have missunderstood your request.
      After reading your request again I read

      I want the agent to get an email notification about the Incident's Status without the Auto-response from the Administrator.

      If I understand you correctly you want:

      1. the agent to receive a notification by email that the incident has been updated
      2. the same notification removed from the message to the customer

      Unfortunately I don't have an interface available where I can test this on for you... but I think you need to remove the append to tread rule as this appends it to the tread to the customer and also use a different email rule. For example the Send escalation message and write your text in the subject and send it to assigned.
       

    • Ryan

      Mirela -
      Short of finding the root cause of your dupe thread entries, you can hide threads of type = Auto-Response in the message template.  Open the properties of the Incident Thread control and deselect the types you'd like to exclude.
      R

    • Mirela Iepure

      Hi Ryan,

      I removed the Auto-Response from all the message templates and it's still showing up in the Email notification both for Agent and Customer. Should I ask the Oracle support team to login as Administrator and remove that as Administrator?

      I think there are some rights that I don't have as simply an admin.

      Best,
      M.

    • Keri

      Hello Mirela,

      I can't tell if you've already modified the Message Templates or not - but once you've made the changes, be sure you have Deployed, then saved the changes. This should simply be a modification of the Incident Thread properties to exclude the Auto-Response thread type from being included in your responses. You'll need to update this in all of the Contact Emails (Incident by various types + the Rule Email) + the Email Incident Information (under Admin Emails area). There should be about 6 messages that get essentially the same type of update.

      See this page in documentation for help.

      Thanks!
      Keri

       

    • Mirela Iepure

      Hello Keri,

      Thank you. It worked both for Agent and Customer. One more issue I still have: the Auto-response is still showing up in the Incident's Workspace. How do I remove it from there too?

      Best,
      M.

    • Keri

      You can't remove that entirely. But you can turn off what you see (each agent can do this). In the thread itself, go to Options, then deselect the applicable check boxes.

    • Mirela Iepure

      Thank you Keri. I will ask them to take this into consideration.