This is a public Forum  publicRSS

Topic

    Mark Russell
    Web Chat now takes users to the Support Centre PageAnswered
    Topic posted March 9, 2018 by Mark RussellRookie, last edited March 9, 2018 
    97 Views, 7 Comments
    Title:
    Web Chat now takes users to the Support Centre Page
    Content:

    Our web chat would normally take the users to an available agent, but all of a sudden once they prompt for their name and email it takes them to the "Support Centre" page to login or register.

    We have not made any changes, has anyone got an idea of why this may be happening?

    Version:
    RightNow Web Chat
    Code Block:

    Best Answer

    Carl Elliott

    It sounds like someone turned on login required.  There is a global setting for this: CP_CONTACT_LOGIN_REQUIRED but it has to get promoted with the code.  

    You can also turn it on for the individual pages.  It would be in the header of the chat pages. 

    Answer

     

    • Carl Elliott

      It sounds like someone turned on login required.  There is a global setting for this: CP_CONTACT_LOGIN_REQUIRED but it has to get promoted with the code.  

      You can also turn it on for the individual pages.  It would be in the header of the chat pages. 

    • Simon Kilgarriff

      As Carl says above if it is in the header it is usually in Line 1:  

      <rn:meta login_required="true"
      
    • Mark Russell

      thank you.

    • Mark Russell

      Just another question, one of the team change this setting via the UI but do we have to deploy this or does the RightNow client do that as we don't have a test instance so i  presumed this would be directly into production? As we are still forced via the support centre page?

    • Anuj Behl

      If it's the config setting that was changed, you wouldn't need to deploy this. Config settings on save are ready to use on all 3 modes of Customer Portal.

    • Carl Elliott

      Anuj, 

      I would have said that too if I had not found this statement: Note that when you change the value of CP_CONTACT_LOGIN_REQUIRED, it only affects the development pages.  You must do a deploy to production for the configuration value to affect your production pages.  Which is in this answer: https://cx.rightnow.com/app/answers/detail/a_id/881

    • Anuj Behl

      Thanks Carl. I did not know individual config settings can have a different behavior than the rest. I stand corrected.

      Thank you.